AutosTalk Forums  

PAJERO 2.8 LOSS OF POWER BLACK SMOKE Yellow dash light?

Mitsubishi Mitsubishi automobiles. (alt.autos.mitsubishi)


Discuss PAJERO 2.8 LOSS OF POWER BLACK SMOKE Yellow dash light? in the Mitsubishi forum.

Reply
 
Thread Tools Display Modes
  #1  
Old   
blue-python
 
Posts: n/a

Default PAJERO 2.8 LOSS OF POWER BLACK SMOKE Yellow dash light? - 05-26-2004 , 03:30 PM






Hello
I have a 1996 2.8 automatic Pajero with a problem. I have taken the car to
Main Mitsi dealer who has read the ECU and it gave these fault codes TC12
Boost Sensor and TC41 Throttle Control Valve. They could not help me any
further! I have disconnected / Blanked off the EGR Valve and I now have
full engine power. The problem is this. Always starts OK, when driving I
have an intermitant fault which the symptoms are: Feels like running out
of fuel / lack of power, yellow dash light comes on, black smoke from
exhaust, sometimes this clears in a few seconds and power comes back up to
100% yellow light stays on, other times engine stays running on low power
and black smoke? So far NO ONE IN THE UK HAS BEEN ABLE TO HELP ME!!! If
anyone can help diagnose the fault that would be great.. To me it seems
like a fuel or air mixture problem? Airflow meter has been mentioned but
how can it be tested? The injection pump is not electronic but is
manually operated with a traditional flexible cable... It will be
interesting to see if anyone has also had this problem around the world.
It is generally an excellent car and I have been very happy with it.
Ideally I would like to have it repaired as soon as possible but unless I
can get an idea of what is wrong it seems like no one in the UK can help!
Look forward to all the replies!!!! Thank you very much for reading and
helping.. Best regards
blue-python UK




Reply With Quote
  #2  
Old   
Nobody U. Know
 
Posts: n/a

Default Re: PAJERO 2.8 LOSS OF POWER BLACK SMOKE Yellow dash light? - 05-31-2004 , 08:52 AM






Is this a turbo vehicle? If not, the boost sensor is probably really a MAP
sensor. That is on the t-body. So is the TPS sensor. I have a feeling the
problem is there. If you see black smoke, that is too rich. The ECU is
probably getting a erroneous signal from the TPS or MAP.

--
"Those who would give up essential Liberty, to purchase a little
temporary Safety, deserve neither Liberty nor Safety."

Benjamin Franklin

Thank you for the Patriot Act you cowards.
"blue-python" <chromerad (AT) nospam (DOT) ukonline.co.uk> wrote

Quote:
Hello
I have a 1996 2.8 automatic Pajero with a problem. I have taken the car to
Main Mitsi dealer who has read the ECU and it gave these fault codes TC12
Boost Sensor and TC41 Throttle Control Valve. They could not help me any
further! I have disconnected / Blanked off the EGR Valve and I now have
full engine power. The problem is this. Always starts OK, when driving I
have an intermitant fault which the symptoms are: Feels like running out
of fuel / lack of power, yellow dash light comes on, black smoke from
exhaust, sometimes this clears in a few seconds and power comes back up to
100% yellow light stays on, other times engine stays running on low power
and black smoke? So far NO ONE IN THE UK HAS BEEN ABLE TO HELP ME!!! If
anyone can help diagnose the fault that would be great.. To me it seems
like a fuel or air mixture problem? Airflow meter has been mentioned but
how can it be tested? The injection pump is not electronic but is
manually operated with a traditional flexible cable... It will be
interesting to see if anyone has also had this problem around the world.
It is generally an excellent car and I have been very happy with it.
Ideally I would like to have it repaired as soon as possible but unless I
can get an idea of what is wrong it seems like no one in the UK can help!
Look forward to all the replies!!!! Thank you very much for reading and
helping.. Best regards
blue-python UK




Reply With Quote
  #3  
Old   
MG
 
Posts: n/a

Default Re: PAJERO 2.8 LOSS OF POWER BLACK SMOKE Yellow dash light? - 05-31-2004 , 09:33 AM



You may want to check the owner forums at www.pocuk.com . POCUK is the
Pajero Owners Club UK. Someone there should be able to help.


Reply With Quote
  #4  
Old   
blue-python
 
Posts: n/a

Default Re: PAJERO 2.8 LOSS OF POWER BLACK SMOKE Yellow dash light? - 06-08-2004 , 03:32 AM



Yes it is a turbo 2.8 ltr and the problem is intermitant. You can drive for
hours whilst towing with no problem and then the next day the fault
happens, it makes no difference the speed or load that you are producing!
Thank you for your suggestion. I will now go back to the Main Mitsi
dealers who frankly have been expensive and have not helped much at all!
(I will never buy a car from them)


Reply With Quote
  #5  
Old   
blue-python
 
Posts: n/a

Default Re: PAJERO 2.8 LOSS OF POWER BLACK SMOKE Yellow dash light? - 06-08-2004 , 03:40 AM



Thank you but so far no one at pocuk has any idea! I have been on several
pocuk chat room and posted a request for help. It has so far been read by
over 165 people with not a single reply or suggestion.

Clearly the problem has to be with the fuel mixture but if the main Mitsi
dealer has no idea where do you turn? They just took 50 off me for
reading ECU and waved me off! I have been calling Colt HQ Uk and they
never call me back even when they promise to find out what the 2 fault
codes mean. Rubbish service and frankly this has really put me off buying
another Pajero!


Reply With Quote
  #6  
Old   
wemfish
 
Posts: n/a

Default Re: PAJERO 2.8 LOSS OF POWER BLACK SMOKE Yellow dash light? - 06-11-2004 , 08:07 AM



Hi,
I cannot find your post on POCUK forum? can you post a link to it as I have
a similar problem with my Mitsubishi Delica 2.5TD



"blue-python" <chromerad (AT) nospam (DOT) ukonline.co.uk> wrote

Quote:
Thank you but so far no one at pocuk has any idea! I have been on several
pocuk chat room and posted a request for help. It has so far been read by
over 165 people with not a single reply or suggestion.

Clearly the problem has to be with the fuel mixture but if the main Mitsi
dealer has no idea where do you turn? They just took 50 off me for
reading ECU and waved me off! I have been calling Colt HQ Uk and they
never call me back even when they promise to find out what the 2 fault
codes mean. Rubbish service and frankly this has really put me off buying
another Pajero!




Reply With Quote
  #7  
Old   
blue-python
 
Posts: n/a

Default Re: PAJERO 2.8 LOSS OF POWER BLACK SMOKE Yellow dash light? - 08-02-2004 , 12:29 PM



Well over 500 now spent with Main Mitsi dealer and they wrongly diagonosed
the problem! If you want a job done do it yourself! I have solved the
problem myself and hope that this information will help other 2.8 ltr
pajero / Shogun owners....... THE PROBLEM WAS........... CRANKSHAFT PULLEY
AND CRANK SENSOR!!!!! The pulley is mounted in rubber and that gave way,
resulting in pulley wobble at low RPM and ok at high RPM centrifugal force
etc, the wobble damaged the sensor and that is why at low RPM I had the
black smoke and yellow light. I have today fitted new pulley, back plate
and sensor (don't ask cost of the parts!!!!!) but dealer did get them next
day for me and a bit of discount.. Now I have the fun of trying to get a
refund on all that labour charges and parts that I did not fit...

So now you all know.... She goes like a new car now!

Cheerio

blue-python


Reply With Quote
  #8  
Old   
blue-python
 
Posts: n/a

Default Re: PAJERO 2.8 LOSS OF POWER BLACK SMOKE Yellow dash light? - 08-02-2004 , 12:29 PM



Well over 500 now spent with Main Mitsi dealer and they wrongly diagonosed
the problem! If you want a job done do it yourself! I have solved the
problem myself and hope that this information will help other 2.8 ltr
pajero / Shogun owners....... THE PROBLEM WAS........... CRANKSHAFT PULLEY
AND CRANK SENSOR!!!!! The pulley is mounted in rubber and that gave way,
resulting in pulley wobble at low RPM and ok at high RPM centrifugal force
etc, the wobble damaged the sensor and that is why at low RPM I had the
black smoke and yellow light. I have today fitted new pulley, back plate
and sensor (don't ask cost of the parts!!!!!) but dealer did get them next
day for me and a bit of discount.. Now I have the fun of trying to get a
refund on all that labour charges and parts that I did not fit...

So now you all know.... She goes like a new car now!

Cheerio

blue-python


Reply With Quote
  #9  
Old   
Den
 
Posts: n/a

Default Re: PAJERO 2.8 LOSS OF POWER BLACK SMOKE Yellow dash light? - 08-03-2004 , 04:08 AM



Hi Blue

Do you mind if I do ask the cost of the parts? and how easy was they to fit?
I don't have the problem now, but you never know ay?

Cheers mate

Den
"blue-python" <chromerad (AT) nospam (DOT) ukonline.co.uk> wrote

Quote:
Well over 500 now spent with Main Mitsi dealer and they wrongly
diagonosed
the problem! If you want a job done do it yourself! I have solved the
problem myself and hope that this information will help other 2.8 ltr
pajero / Shogun owners....... THE PROBLEM WAS........... CRANKSHAFT PULLEY
AND CRANK SENSOR!!!!! The pulley is mounted in rubber and that gave way,
resulting in pulley wobble at low RPM and ok at high RPM centrifugal force
etc, the wobble damaged the sensor and that is why at low RPM I had the
black smoke and yellow light. I have today fitted new pulley, back plate
and sensor (don't ask cost of the parts!!!!!) but dealer did get them next
day for me and a bit of discount.. Now I have the fun of trying to get a
refund on all that labour charges and parts that I did not fit...

So now you all know.... She goes like a new car now!

Cheerio

blue-python




Reply With Quote
  #10  
Old   
Javert
 
Posts: n/a

Default Re: Mitsubishi Pajero 2.8 LOSS OF POWER BLACK SMOKE Yellow dash light? - 04-11-2009 , 10:11 PM







blue-python;1693521 Wrote:
Quote:
Hello
I have a 1996 2.8 automatic Pajero with a problem. I have taken the car
to
Main Mitsi dealer who has read the ECU and it gave these fault codes
TC12
Boost Sensor and TC41 Throttle Control Valve. They could not help me
any
further! I have disconnected / Blanked off the EGR Valve and I now
have
full engine power. The problem is this. Always starts OK, when driving
I
have an intermitant fault which the symptoms are: Feels like running
out
of fuel / lack of power, yellow dash light comes on, black smoke from
exhaust, sometimes this clears in a few seconds and power comes back up
to
100% yellow light stays on, other times engine stays running on low
power
and black smoke? So far NO ONE IN THE UK HAS BEEN ABLE TO HELP ME! If
anyone can help diagnose the fault that would be great.. To me it
seems
like a fuel or air mixture problem? Airflow meter has been mentioned
but
how can it be tested? The injection pump is not electronic but is
manually operated with a traditional flexible cable... It will be
interesting to see if anyone has also had this problem around the
world.
It is generally an excellent car and I have been very happy with it.
Ideally I would like to have it repaired as soon as possible but unless
I
can get an idea of what is wrong it seems like no one in the UK can
help!
Look forward to all the replies! Thank you very much for reading and
helping.. Best regards
blue-python UK

Hi there, I live in new zealand and have exactly the same problem you
are describing with yours. I know this is a long time after you first
encountered the problem but i was wondering what you ended up doing to
remedy the problem?


--
Javert
Message origin: www.TRAVEL.com



Reply With Quote
Reply




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.